We have successfully completed the scheduled maintenance. The enhancements have been implemented, and normal operations have been restored. Thank you for your patience and cooperation during this maintenance period. Should you encounter any issues, please reach out to our support team for assistance.
Posted Feb 27, 2025 - 06:37 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 27, 2025 - 06:00 UTC
Scheduled
We will be performing planned maintenance on our Online Scheduler (Member Website) & Online Scheduler (iConnectYou) applications to implement important enhancements and optimize our systems. During this time, there might be temporary disruptions in the service. We apologize for any inconvenience caused and appreciate your understanding. The maintenance window is scheduled as follows:
Date: 27-Feb-2025 Start Time: 06:00 AM UTC End Time: 06:45 AM UTC
Posted Feb 25, 2025 - 10:12 UTC
This scheduled maintenance affected: Member Website (Online Scheduler (Member Website)) and Mobile Applications (Online Scheduler (iConnectYou)).